circuitpython/ports/unix/variants/coverage
Jeff Epler 52bca95208
Refactor dotenv module so that it can be tested on host
.. it needs to operate on a FILE* rather than FIL depending on
the build.

Note that this is comparing output to expected, not to cpython dotenv
package. Because run-tests.py starts the CPython interpreter with the
'-S' (skip site initialization) flag, pip-installed packages are
not available for import inside a test file. Instead, the exp
file is generated manually:
```
circuitpython/tests$ python3 circuitpython/dotenv_test.py > circuitpython/dotenv_test.py.exp
```

Unfortunately, the test fails on test e15:
```diff
FAILURE /home/jepler/src/circuitpython/tests/results/circuitpython_dotenv_test.py
--- /home/jepler/src/circuitpython/tests/results/circuitpython_dotenv_test.py.exp	2022-10-04 09:48:16.307703128 -0500
+++ /home/jepler/src/circuitpython/tests/results/circuitpython_dotenv_test.py.out	2022-10-04 09:48:16.307703128 -0500
@@ -14,7 +14,7 @@
 line
 e13 e13value
 e14 None
-e15 e15value
+e15 None
 e16 #
 e17 def
 e18 #has a hash
```
2022-10-04 09:51:27 -05:00
..
frzmpy Add frzqstr to coverage build 2021-05-05 11:00:39 -05:00
frzstr Merge MicroPython 1.13 into CircuitPython 2021-05-04 18:06:33 -07:00
manifest.py unix: Make manifest selection match other ports. 2020-07-01 22:42:55 +10:00
mpconfigvariant.h Merge tag 'v1.18' 2022-02-15 12:36:26 -06:00
mpconfigvariant.mk Refactor dotenv module so that it can be tested on host 2022-10-04 09:51:27 -05:00